Block 64 Cloud Services

Incident Report for Block 64 Service

Resolved

Azure have resolved their outage and Block 64 services are now operational
Posted Oct 29, 2025 - 19:46 EDT

Update

As per Azure's most recent status update (https://azure.status.microsoft/) full remediation is expected within 4 hours. We will continue to monitor the situation.
Posted Oct 29, 2025 - 15:23 EDT

Identified

As per Azure Status (https://azure.status.microsoft/en-us/status) several Azure resources are down and have impacted Block 64 services. When Azure service is restored, Block 64 service should resume.
Posted Oct 29, 2025 - 13:12 EDT

Investigating

We are currently investigating this issue.
Posted Oct 29, 2025 - 12:44 EDT
This incident affected: Web Services (Combine Analytics Portal, Combine API, Block 64 Insights).